Forza Horizon 4 PC Performance Thread

For those of you with RTSS issues:
In RTSS go to SETUP and put 15000 for injection delay at the bottom.

This also fixes ubisoft overlay not working in r6:S/etc.
RTSS will delay start until after the game is running. I haven't had any problems.
This makes no difference for me and was already at that setting when I went into RTSS. Even adding an extra 0 on to the figure doesn't work.
 
I still can't get the demo to work.

I updated my video drivers, updated windows, uninstalled it and re-installed it on different drives, disabled my antivirus, I don't have any overlay stuff running but nothing seems to work, it just shows the Forza 4 logo, then a window with a black screen and then back to desktop. This is really getting frustrating.
 
I still can't get the demo to work.

I updated my video drivers, updated windows, uninstalled it and re-installed it on different drives, disabled my antivirus, I don't have any overlay stuff running but nothing seems to work, it just shows the Forza 4 logo, then a window with a black screen and then back to desktop. This is really getting frustrating.
Has to be something to do with your sound device.
 
I still can't get the demo to work.

I updated my video drivers, updated windows, uninstalled it and re-installed it on different drives, disabled my antivirus, I don't have any overlay stuff running but nothing seems to work, it just shows the Forza 4 logo, then a window with a black screen and then back to desktop. This is really getting frustrating.
Sounds similar to the problem I had with Forza Horizon 3 on PC. I had to disable my onboard graphics card in Device Manager and just have my Nvidia card enabled for it all to work.
 
I had that issue at first but I think they fixed it, launches fine with Atmos enabled now for me.
Does Atmos do anything in this game?

Every game I've tried Atmos for headphones with it seemed to do nothing, because the game was not outputting in surround due to windows detecting my sound device as stereo.
 
Has to be something to do with your sound device.
Like what? It's set on my sound card and switching to my on board card also doesn't change a thing.


Sounds similar to the problem I had with Forza Horizon 3 on PC. I had to disable my onboard graphics card in Device Manager and just have my Nvidia card enabled for it all to work.
My videocard is the only thing listed in the device manager.
 


I don't know why stuttering is so fucking awful. Even if I bump everything down to medium, the best I can get in the bench is 58 stutters.
Looks like there are some regular drops on the yellow GPU graph but also on the CPU blue one.

Do you have something running in the background like websites, animated wallpaper or slideshow wallpaper ?
Try closing some apps one by one to check what is causing this.
 
GeForce 1070 and 1TB ssd have been put into my pc. Let's see how this is going to turn out tomorrow :)
From my non-scientific testing, resolution/res-related settings are the killer.

I'm on 6700K/8GB/980Ti @ stock and at 1080p w/ everything but FXAA on highest (including forced MFAA + 8xSS) it is all but locked @ 60FPS.

Even if I knock some of the demanding stuff off, as soon as I jump to 1440p it starts to shit the bed and it isn't a RAM limitation.
 
My application suddenly stopped launching :/

I pinned it to the taskbar and have been playing since yesterday, I go to launch it and it closes itself after the splash screen with the grey background. fml
 
From my non-scientific testing, resolution/res-related settings are the killer.

I'm on 6700K/8GB/980Ti @ stock and at 1080p w/ everything but FXAA on highest (including forced MFAA + 8xSS) it is all but locked @ 60FPS.

Even if I knock some of the demanding stuff off, as soon as I jump to 1440p it starts to shit the bed and it isn't a RAM limitation.
Yeah, I was wondering if I needed to upgrade my ram too. Only 12GB ram as of now.

Gonna play with the settings a bit when I can play. Was hoping to get above 1080/60.
 
Looks like there are some regular drops on the yellow GPU graph but also on the CPU blue one.

Do you have something running in the background like websites, animated wallpaper or slideshow wallpaper ?
Try closing some apps one by one to check what is causing this.
Disabling and closing everything else I possibly can has no impact on the stuttering. It's still just as bad.

Even if I go for the Very Low preset, I can't eliminate it entirely.
 
Disabling and closing everything else I possibly can has no impact on the stuttering. It's still just as bad.

Even if I go for the Very Low preset, I can't eliminate it entirely.
I feel like an idiot for asking but any how: does it stutter during gameplay or just on the benchmark? Have you tried going 'offline' from Horizon life and seeing if it improves?

Also - what temp is your CPU/GPU at?
 
I can't join any multi-player lobby .. That sucks
It's likely a Teredo issue. Very common with microsoft games sadly. Google should have a bunch of suggestions. It's not a game issue but rather a Windows 10 service issue. I had it too - I ended up reinstalling my OS to fix it. But there's people that managed to fix it with less drastic methods.
 
I feel like an idiot for asking but any how: does it stutter during gameplay or just on the benchmark? Have you tried going 'offline' from Horizon life and seeing if it improves?

Also - what temp is your CPU/GPU at?
It's noticeable during gameplay and the benchmark.

I was offline for most of the first day I played it and it was happening just as bad there.

During the benchmark, GPU tops out at 62C, CPU at 70C
 
It's noticeable during gameplay and the benchmark.

I was offline for most of the first day I played it and it was happening just as bad there.

During the benchmark, GPU tops out at 62C, CPU at 70C
Does it happen in other games ?
If you let your PC idle and with Task Manager open, do you notice regular spikes in the CPU usage graph ?
 
I solved it.

My Windows Power Plan had somehow reverted back to balanced (which scales CPU power between 5 and 100%).

Setting it to High Performance eliminated the issue instantly. Night and Day difference.

 
Is there any way to increase LOD? Seeing a decent amount of pop-in on vegetation and on other cards, close enough that it's distracting. I've got my settings basically maxed out, so I'm wondering about any extracurricular solutions.
 
Last edited:
Man this thing absolutely eats my 6600K for lunch. Everything else is completely fine, but the CPU usage is through the roof in a way I've never seen before. It runs fine most of the time, but I've run into rendering issues as a result. Is this just like 3 where it's extremely unoptimized?
 
Man this thing absolutely eats my 6600K for lunch. Everything else is completely fine, but the CPU usage is through the roof in a way I've never seen before. It runs fine most of the time, but I've run into rendering issues as a result. Is this just like 3 where it's extremely unoptimized?
No, this game is extremely optimized all things considered. You can run the in game benchmark, which is very robust, to confirm if you are being CPU bottlenecked. But really, you shouldn't have any issues playing the game as far as your CPU is concerned. How do you know rendering issues are caused by your CPU? What issues are you having, what are you other specs: GPU, RAM, etc?
 
Yeah, three crashes now in the space of 20hrs I guess. The last two completely locked up my PC. It was fine for the first day but seems to be becoming more unreliable. Of course 3 crashes isn't a lot but, for context, I've put hundreds of hours into Destiny 2 and AC: Origins and I don't remember the last time they crashed, if ever. Shadow of the Tomb Raider has more bells and whistles graphically but, ignoring the sli menu bug, it's also been flawless. It is possible to make PC games run well. But not horizon games unfortunately. Still, could be worse. Let's see if it gets worse.
 
Doing the benchmark gives odd results (though i think this may be because restarting after changing settings doesn't work properly). Anyway, I start at everything max, 3440x1440 and 2xMSAA and I get
At 4xMSAA I get
At all Ultra and 2xMSAA I get
And at all High and 2xMSAA I get
I lose one frame on average between 4xMSAA and 2xMSAA on max settings. And when I got to high and 2xMSAA and hit 100fps I get a stutter rate of 64 compared to the 3 or 4 from earlier. In the end I'm keeping it at max and 2xMSAA as the texture pop up and LoD on trees and bushes is too severe at High, though that may be an issue with restarting the game from the Video settings screen.
 
Is there any way to increase LOD? Seeing a decent amount of pop-in on vegetation and on other cards, close enough that it's distracting. I've got my settings basically maxed out, so I'm wondering about any extracurricular solutions.
As long as the world geometry setting is at extreme that’s all you can do.
 
Oh and this is what happens to my desktop when I quit the game.
The same issue happens to me when SLI is enabled.
Not just for this game but others too. I think this issue is more to do with NVIDIA rather than FH4.

Have to restart Windows Explorer in task manager to get tiles back to normal, or disable SLI so it doesn't occur in the first place.
 
Is there any way to increase LOD? Seeing a decent amount of pop-in on vegetation and on other cards, close enough that it's distracting. I've got my settings basically maxed out, so I'm wondering about any extracurricular solutions.
Did you play the demo? If so, was it the same?

Compared to FH3 which had very obvious and annoying pop up, this has far less, but might not be enough to satisfy everyone.

Game unlocks in 7 hrs!

The only issue I had in FH3 demo was the game would crash often during the splash screens.
 

matimeo

UI/UX Game Industry Veteran
Verified
My application suddenly stopped launching :/

I pinned it to the taskbar and have been playing since yesterday, I go to launch it and it closes itself after the splash screen with the grey background. fml
I had something similar happen only it would crash at the Microsoft studios logo movie.

What worked for me was going into FH4 app settings in windows and resetting the app. Then ensure you launch the FH4 app as administrator.

The game will make you set up your video options again but will sync and grab your save game.

That worked for me.
 
Excited to try this out. Will probobly play mostly on my X1X for now, but excited to try in on my Surface Book 2.


i78650u
GTX 1060 6GB
16GB Ram
1TB SSD
From the DF video I can probobly expect pretty damned good performance no?

Love the resolution support.
When I build my 2080ti /Ultrawide GSync HDR rig, this will like be a showcase game.
 
Maybe worth knowing that when I used triple screens with forza horizon 3, I had to change to single screen and start the game then once in the game, alt-tab out and change to 3 screens. It may or may not still exist as I changed to using a 32:9 monitor.
 
I finally got my demo to work, after an entire day of ruling things out it turned out the game won't launch when Comodo Antivirus is running, disabling it would not work but after uninstalling it it worked.

Game runs super smooth on my setup, everything set to ultra on 1440P on a GTX1080, a big improvement on Horizon 3.
 
Top